PPP/Serial/POS
PPP (Point-to-Point Protocol) is defined in RFC 1661.
PPPoE (PPP over Ethernet) is described in RFC 2516.
Serial
Don't forget to to set the clock rate (i.e. 64000) on the DCE interface (usually the one on the service provider router).
PPP
You can use "no peer neighbor route" in order to disable creating a /32 for the peer address.
Multilink PPP
R1 (IOS)
interface Serial2/0
encapsulation ppp
ppp multilink
ppp multilink group 1
clock rate 64000
!
interface Multilink1
ip address 12.12.12.1 255.255.255.0
ppp multilink
ppp multilink group 1
R2 (IOS)
interface Serial0/0
encapsulation ppp
ppp multilink
ppp multilink group 1
!
interface Multilink1
ip address 12.12.12.2 255.255.255.0
ppp multilink
ppp multilink group 1
Multichassis Multilink PPP
SGBP is used between routers to coordinate them for multilink ppp termination.
R4 (IOS)
sgbp group SGBP-GRP
sgbp member R5 5.5.5.5
sgbp source-ip 4.4.4.4
!
username SGBP-GRP password 0 SGBP-PASS
!
multilink virtual-template 1
!
interface Virtual-Template1
ip unnumbered Loopback0
ppp multilink
R5 (IOS)
sgbp group SGBP-GRP
sgbp member R4 4.4.4.4
sgbp source-ip 5.5.5.5
username SGBP-GRP password 0 SGBP-PASS
!
multilink virtual-template 1
!
interface Virtual-Template1
ip unnumbered Loopback0
ppp multilink
IOS
R4#sh sgbp
Group Name: SGBP-GRP Ref: 0xDE80000
Seed bid: default, 50, default seed bid setting
Member Name: R5 State: active Id: 1
Ref: 0xABC0000
Address: 5.5.5.5
Other Active Address: 20.4.5.5
PPPoE
IOS
PPPoE server
bba-group pppoe global
virtual-template 1
!
interface Virtual-Template1
mtu 1492
ip address 10.10.10.1 255.255.255.0
!
interface X
pppoe enable group global
PPPoE client
interface X
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address 10.10.10.2 255.255.255.0
encapsulation ppp
dialer pool 1
Interface X is assumed to be an ethernet interface.
You must define "encapsulation ppp" under the dialer, otherwise the ppp call won't happen.
Not all routers support the PPPoE functionality.
PPPoE server/client is not supported on IOS-XR of C12k.
PPP Authentication
IOS
Server
username USERNAME password PASSWORD
!
interface POS2/0
encapsulation ppp
ppp authentication chap
Client
interface POS2/0
encapsulation ppp
ppp chap hostname USERNAME
ppp chap password PASSWORD
If you don't define a chap hostname, then the router's name is used as the username.
In the following example the first router authenticates the second using CHAP (encrypted), while the second router authenticates the first using PAP (cleartext).
IOS
Server & Client #1
username R2-USER password R2-PASS
!
interface POS2/0
encapsulation ppp
ppp authentication chap
ppp pap sent-username R1-USER password R1-PASS
Server & Client #2
username R1-USER password R1-PASS
!
interface POS2/0
encapsulation ppp
ppp authentication pap
ppp chap hostname R2-USER
ppp chap password R2-PASS
POS (Packet over SONET/SDH)
POS default MTU is 4470.
MPLS-TE isn't supported on POS frame-relay subinterfaces on C12k running IOS-XR.
POS Configuration
You will find most configurations parameters under the following command:
IOS
R1(config-if)#pos ?
ais-shut Send LAIS when shutdown
delay Delay POS alarm triggers
flag Specify byte value
framing specify framing
report enable reporting of selected alarms
scramble-atm Enable POS SPE scrambling
threshold Set BER threshold values
Verification checks can be performed with:
IOS
R1#sh controllers pos2/0
POS2/0
SECTION
LOF = 0 LOS = 0 BIP(B1) = 0
LINE
AIS = 0 RDI = 0 FEBE = 0 BIP(B2) = 0
PATH
AIS = 0 RDI = 0 FEBE = 0 BIP(B3) = 0
PLM = 0 UNEQ = 1 TIM = 0 TIU = 0
LOP = 0 NEWPTR = 0 PSE = 0 NSE = 0
Active Defects: PUNEQ
Active Alarms: None
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA
Framing: SONET
APS
COAPS = 0 PSBF = 0
State: PSBF_state = False
Rx(K1/K2): 00/00 Tx(K1/K2): 00/00
S1S0 = 00, C2 = 00
Remote aps status (none); Reflected local aps status (none)
CLOCK RECOVERY
RDOOL = 0
State: RDOOL_state = False
PATH TRACE BUFFER: STABLE
Remote hostname :
Remote interface:
Remote IP addr :
Remote Rx(K1/K2): / Tx(K1/K2): /
BER thresholds: SF = 10e-3 SD = 10e-6
TCA thresholds: B1 = 10e-6 B2 = 10e-6 B3 = 10e-6
Clock source: line
Don't expect all things to work in GNS3.
Keepalives
The keepalive command applies to serial interfaces using HDLC or PPP encapsulation. It does not apply to serial interfaces using Frame Relay encapsulation.
Keepalives are independent between the two peers. One peer end can have keepalives enabled; the other end can have them disabled. Even if keepalives are disabled locally, LCP still responds with ECHOREP packets to the ECHOREQ packets it receives.
CRC
The cyclic redundancy check (CRC) on a serial interface defaults to a length of 16 bits. You can change it to 32 bits.
IOS
interface POS2/0
crc 32
IOS
R1#sh int pos2/0
POS2/0 is up, line protocol is up
Hardware is Packet over Sonet
Internet address is 10.10.10.1/24
MTU 4470 bytes, BW 155000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 32, loopback not set
POS Channel
POS channel link bundling provides load-balancing across all active links in a bundle.
IOS
interface pos-channel 1
ip address 30.30.30.1 255.255.255.0
!
interface pos2/0
channel-group 1
!
interface pos3/0
channel-group 1
POS link bundling is supported on very specific hardware.
APS
The APS feature provides redundancy and allows for a switchover of POS circuits in the event of circuit failure.
You configure a pair of SONET/SDH lines for line redundancy. When the Working (W) interface fails, the Protect (P) interface quickly assumes the traffic load (usual swichover time is 50 ms)
Most configuration options are found under the "aps" command:
IOS
R1(config-if)#aps ?
authentication Authentication string
force Force channel
group Group association
lockout Lockout protection channel
manual Manually switch channel
protect Protect specified circuit
reflector Configure for reflector mode APS
revert Specify revert operation and interval
signalling Specify SONET/SDH K1K2 signalling
timers APS timers
unidirectional Configure for unidirectional mode
working Working channel number
Configuration
IOS
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface POS2/0
ip address 10.10.10.1 255.255.255.0
aps group 10
aps working 1
!
interface POS3/0
ip address 20.20.20.1 255.255.255.0
aps group 10
aps protect 1 1.1.1.1
aps revert 1
You need the configure a similar setup on the peer router too.
You can have the Working and Protect interfaces on different routers and they will communicate each other using PGP (Protect Group Protocol), which runs over UDP.
IOS
R1#sh aps
POS3/0 APS Group 10: protect channel 0 (Inactive)
Working channel 1 at 1.1.1.1 (Enabled)
bidirectional, revertive (60 seconds)
PGP timers (default): hello time=1; hold time=3
hello fail revert time=120
SONET framing; SONET APS signalling by default
Received K1K2: 0x00 0x00
No Request (Null)
Transmitted K1K2: 0x00 0x05
No Request (Null)
Remote APS configuration: (null)
POS2/0 APS Group 10: working channel 1 (Active)
Protect at 1.1.1.1
PGP timers (from protect): hello time=1; hold time=3
SONET framing
Remote APS configuration: (null)
You need an ADM between the routers for the K1/K2 signals to work.
No comments:
Post a Comment